http://marcdekeyser.com

The information store service is stopped and will not start

Troubleshooting the information store service can be straightforward yet immensely complicated if you don’t know what is going on. For this reason I think it is important to know that there are 3 likely culprits that will cause your information store service to go down and refuse to come up:

· Database problems
· Active directory problems
· Antivirus software

Trying to work out which is the culprit can be hard, elimination is probably the easiest way to work through this… So let us get started!

1. Open Exchange Management Console (or the Exchange System Manager if you're on 2003)
2. Expand until you reach the database
3. Open the properties of the database
4. Check "Do not mount this database on start up"
5. Click ok
6. Open services.msc

Next:

1. Open Start, run
2. Type in services.msc, click "OK"
3. Scroll down until you reach the Microsoft Exchange Information Store Service.
4. Right click the IS service and try to start it.
5. Does it start?

If the IS service mounts at this point you're most likely going to have a corrupt database. Open a command prompt and run the "ESEUTIL /mh <path to priv1.edb>" command. Scroll down until you see the "State" and "Log required" Field:

     

clip_image001

     

If you have the database state on "Dirty Shutdown" you'll need to run the following commands on the database:
1. Eseutil /p <path to priv1.edb>
2. Eseutil /d <path to priv1.edb>
3. ISInteg -s "server name" -test alltest -fix
Follow the on screen instructions for the ISInteg and repeat ISInteg until all errors have been corrected. This is extremely important as ISInteg fixes the database tables and will either fix or get rid of corrupt items.
Depending on how big your database is it might take a while to complete the database recovery. If you need to get your users back online fast you can use the Dial-tone recovery method. This means you'll move all the files in the physical location of the database where you can perform the recovery and mount the database in ESM or EMC. It will tell you that it could not find a database and ask you if it can create a new (blank) database. If you confirm a new database can be mounted and users can access new emails that are received if they are in online mode and access their old mails only if they have the cached mode enabled.
Now, in case the above did not get your service to start up you have reached a pickle. We need to find out if it's an AD or AV issue!
1. Open Start, run
2. Type in services.msc, click "OK"
3. Scroll down until you reach the Microsoft Exchange services.
4. Note what services are down. Is only the IS service not functional or is the transport service down as well?
Note: If you're transport service is down as well the likely hood of it being an Active Directory issue increases!

Try starting the IS Service, it will error out but what is important is that you will now have some events logged in the application log. In most cases these events will be ID 5000 and 1121.

Going into the event log:
1. Open start, run
2. Type in eventvwr, click "OK"
3. expand until you hit the "Application log"
4. Identify the recent events from source "MSExchangeIS"
5. Also have a look at the events from source "ADAcces"
If events 5000 and 1121 are logged they should point you in the right direction for what is wrong with the AD. Usually it's Exchange that cannot contact the GC (so check if the domain controllers are reachable!. In that case there's a quick and dirty workaround. Note that you should only do this to restore functionality for your environment and it is a temporary measure. After you repair the AD issues you are highly advised to let Exchange choose its DC/GC!

For Exchange 2003:

1. Open the Exchange System Manager
2. Expand untill you hit your Exchange server
3. Open the properties of the Exchange server
4. Switch to the "Directory Access" tab
5. Select "Domain Controllers" in the drop down list
6. Select a working DC
7. Deselect "Automatically discover Servers"
Note: If your Exchange server is installed on a Dc it will always contact that DC, no matter what you set in this field.

For Exchange 2007:
1. Open the Exchange management shell (powershell for Exchange)
2. Use the “Set-Exchangeserver -StaticConfigDomainController -StaticDomainController –StaticGlobalCatalog” command.
Note: If your Exchange server is installed on a Dc it will always contact that DC, no matter what you set in this field. For Exchange 2010 you can use the same command as for Exchange 2007.

In case there are no events 5000 & 1121 you'll most likely have events 9565 & 9564 logged. These are caused by the antivirus program being broken. You'll want to disable the antivirus key in the registry:

1.Click Start, and then click Run.
2.In the Open box, type regedit, and then click OK.
3.In Registry Editor, locate the following subkey in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\VirusScan
4.In the right pane, double-click Enabled.
5.Click Decimal, type 0 in the Value data box, and then click OK.
6.On the File menu, click Exit to quit Registry Editor.
7.Start the Information Store.
http://support.microsoft.com/kb/323664
Remove your AV in a service window and reboot the server.

 

Technorati Tags: ,,,,,,,,,,,
,,,,,,,,,,,,,,,
,,,,,,,,,,,,,,
,,,,,,,,,,,,
,,,,,,,
,,,,,,

Feedback

# re: The information store service is stopped and will not start

You, Sir, Are a genius.
I have been battling all day with a 250 mailbox server and trying edb recovery, manual AV registry searches and untold Googlage.
I know this happened after the first reboot after uninstalling ESET and the registry change from 1 to 0 fixed it immediately.
Many thanks for this blog, you have prevented a nervous breakdown. 12/8/2013 5:58 PM | Rowdy

# re: The information store service is stopped and will not start

Glad I could help Rowdy! 12/8/2013 7:18 PM | Marc

# re: The informatiThe information store service is stopped and will not starton store service is stopped and will not start

Thank you sir for the post!!! Really fixed my issue that I was trying from 2 Days!! 2/24/2017 11:41 PM | Ashis