Geeks With Blogs

News





INauseous() Shawn Cicoria - Solution Architect, Craftsman and Artisan - INauseous() - Main Blog Here: www.Cicoria.com

I've been running Vista on a Toshiba M5 for quite some time.  Since the RTM, the drivers for the 3945ABG driver from Intel have been garbage.  Tried each one as they came out from Intel's site here:

http://downloadcenter.intel.com/Filter_Results.aspx?strOSs=All&strTypes=All&ProductID=2259&OSFullName=All%20Operating%20Systems&lang=eng

So, back in late August, I was checking Dell's support site on a different machine and noticed that the drivers that Dell was publishing for the Intel 3945ABG were a later version.  Intel's site didn't have them - nor does Toshiba.

So, since then, I've been running with the drivers (which are built by Intel) from the Dell site for the 3945ABG from this link:

Installer package for driver version 11.1.1.22

Haven't had a problem since.  There used to be issues that would intermittently drop the connection forcing a manual reset with the HW switch on the outside of the M5.  Even one error which showed up in the event log that was only addressed by a reboot.  It was so bad I pulled out an older PC Card WIFI adapter to use until I was able to reboot.

I don't get Toshiba or Intel - I've found this error posted across many forums, Technet. Microsoft, Ars Technical, Vista Forums.  This is the state of affairs when it comes to quality and support and why these guys are failing.

Posted on Thursday, October 18, 2007 9:19 AM | Back to top


Comments on this post: Intel 3945ABG, Vista, and Driver Quality Issues - Dell has the latest & best...

# re: Intel 3945ABG, Vista, and Driver Quality Issues - Dell has the latest & best...
Requesting Gravatar...
I have exactly the same problem on an Asus laptop - I'll be trying this! You're a star for reporting on it.
Left by TheFish on Nov 01, 2007 1:46 AM

# re: Intel 3945ABG, Vista, and Driver Quality Issues - Dell has the latest & best...
Requesting Gravatar...
Hello,

Please can anyone help with this?? I have updated to the latest driver version 11.1.1.22 but yet I can't connect. Always complaining says limited connectivity. My operating system is vista.
Even, then very first time I updated to the latest version, on the ADVANCE beside DRIVER in <device manager> I could see 13 parameters, later reduced to 9 and now its 8. I think those parameters are missing that is why I can not connection.
Now, I just format the PC so I have the driver that can with the PC from factory then I updated the again with the hope that it those parameters will be completed whenI load it but still the same 8 instead of 13.
Please I need help on this.
Network Card Inter Pro Wireless 3945ABG
Latest Version
OS: Vista
Toshiba

Thanks.
Left by Tosfax on Nov 01, 2007 10:09 AM

Comments have been closed on this topic.
Copyright © Shawn Cicoria | Powered by: GeeksWithBlogs.net