Geeks With Blogs

News


Andy Morrison's BizTalk Blog Help, I've fallen and I can't BizTalk!

I had this exception in the Application Event Log after trying to bring up the portal in IE (after a newly installed and configured BizTalk & ESB platform):

---

Exception information:
    Exception type: WebException
    Exception message: The remote server returned an error: (401) Unauthorized.

---

I was working in a two (application) server BizTalk environment but I only had this exception on one server.  The portal came up fine on the other server.

I looked at IIS log files and found a 401 for /ESB.Exceptions.Service/ExceptionService.svc/GetUserSettings

I browsed to the /ESB.Exceptions.Service/ExceptionService.svc in IE and saw this in the Application Event Log:

---

Exception information:

Exception type: NotSupportedException

Exception message: Security settings for this service require Windows Authentication but it is not enabled for the IIS application that hosts this service.

---

Uhh... I did have that configured: Windows Integrated was turned on and Anonymous was turned off.

The issue was that I did not run the set command for NTAuthenticationProviders (specified in this KB: http://support.microsoft.com/kb/215383) on that server.  I had previously ran the set command on the other server in my environment before running the Microsoft.Practices.ESB.UDDIPublisher.exe

Posted on Thursday, February 25, 2010 12:57 PM BizTalk , ESB Toolkit 2.0 | Back to top

Copyright © Andy Morrison | Powered by: GeeksWithBlogs.net