Geeks With Blogs
Molnar Tibor blog January 2008 Entries
MOSS 2007 Service Pack 1 installation adventure
We installed first time in a stressy condition the SP1 for a production server (a simple farm installation). There was an error during running a custom workflow (developed in Visual Studio 2005) attached to a custom list; we googled out that it was a MOSS bug solved by SP1, which was not installed yet. The plan was to install SP1 and restore a backup from previous midnight for the content database in order to regain the status of a workflow which crashed due to the MOSS bug mentioned above. What ......

Posted On Sunday, January 27, 2008 7:44 PM

'Object moved' WebException when calling Project server interface (PSI) web services
Recently I created a web part for Project Server 2007 and I had to use PSI which is a set of web services which are coming withe the PS 2007 installation. When a PSI web service is addded in Visual Studio to a project, the chosen web service url has the form of http://{machinename}/pwa/_v... but in the app.config file and in the settings class of the project, for a reason unknown by me the url of the web service is set to http://{machinename}/_vti_b... ......

Posted On Tuesday, January 22, 2008 9:42 PM

MOSS api programming gotcha: existing group is not retreived in SPWeb instance Groups collection attribute

A possible reason for this is that a group is created without any attached permission level. The Change Group Setting page allows to do this, the result is that the Groups collection of an SPWeb instance doesn't contain the created group. Solution: attach at least one permission level to the group on the group settings page :-) .

Posted On Wednesday, January 9, 2008 9:45 PM

Copyright © Molnar Tibor | Powered by: GeeksWithBlogs.net