Geeks With Blogs
Theo Moore Questions... Morphology? Longevity? Incept dates?

Well, the install is complete. Once I got the correct permissions and the access to the correct software, it went pretty smoothly. However, I did run into one issue. During the install I got a 32000 error referring to the STS_CONFIG_TFS database being accessed by stsadm.exe. The exe was being used to configure the Sharepoint database, and was having trouble. I verified that all the pieces/parts existed and made sure the user account for setup was properly configured. All this was fine, so I changed my install process. Instead of the "silent" install for Sharepoint services, I did the manual one EXACTLY as listed in the install guide. You must NOT configure anything in Sharepoint during the install; as soon as the browser with the options appears, close it. There is a switch in the silent process that should prevent any configuration, but something must be configured anyway.

Another gotcha I've read about is that FrontPage Extensions may cause you grief, even after removing them. Some people have had to wipe and an reinstall their server to get it to work. Thankfully, I've not had that problem.

I did feel the troubleshooting available for the install was pretty weak overall, and it would be great to have some common errors listed for you.

If you do run into problems, you might find some help in the forums . Good luck.

Posted on Thursday, November 2, 2006 3:23 PM | Back to top


Comments on this post: VSTS Install issues

# re: VSTS Install issues
Requesting Gravatar...
Hey Theo,

Next time you need to do an install, check out my scripts (on my blog there is a link to them). I automates (scripts) all the pre-req and you just need to install TFS at the end it even start the install you need to click next a few times. WSS is installed silently so is SQL server and SP1 of SQL server. Good luck with you new server VSTS and TFS are very cool products.

Cheers,

ET
Left by ET on Nov 03, 2006 9:48 AM

# re: VSTS Install issues
Requesting Gravatar...
Cool. Thanks for the input. I'll check those out. I am having trouble figuring out how to connect my VSTS install to the TFS though.....
Left by Theo Moore on Nov 03, 2006 9:52 AM

# re: VSTS Install issues
Requesting Gravatar...
What kind of connection issues?
Left by ET on Nov 03, 2006 10:02 AM

# re: VSTS Install issues
Requesting Gravatar...
Well, I am sort of embarrased to mention it, really. I have the TFS server installed, but the VSTS install doesn't seem to know it's there. I can't seem to find any documentation on how to get the two to talk. For example, the source control tools are all greyed out in the VS IDE. I confess I am at a loss....

Left by Theo Moore on Nov 03, 2006 10:04 AM

# re: VSTS Install issues
Requesting Gravatar...
Where you using VSS before? I so I think I know your problem, go in the options of VS and look at the source control section. In there switch the SC provider to Team Foundation Server Version Control and you should be good to go. Le me know.

Cheers,

ET
Left by ET on Nov 03, 2006 10:26 AM

Your comment:
 (will show your gravatar)
 


Copyright © Theo Moore | Powered by: GeeksWithBlogs.net | Join free