Terje Sandstrom

------ Chief Software Geek at Inmeta Consulting in Scandinavia ----- and a Visual Studio ALM MVP

  Home  |   Contact  |   Syndication    |   Login
  59 Posts | 1 Stories | 95 Comments | 0 Trackbacks

News

Subscribe

Delicious Save this on Delicious Visual Studio Feeds

¨

Tag Cloud


Article Categories

Archives

Post Categories

Image Galleries

Company stuff

Interesting bloggers

Interesting companies

Microsoft

Microsoft Norge

Microsoft Regional Directors

Microsoft Test

MSFT Blogs

MVP

NNUG

Other interesting stuff

TFS

Visual Studio

Tuesday, June 5, 2012 #

Updated: June 7th 2012:  Cause for the issues found! Unsupported scenario having TFS 11 Beta side-by-side.  Uninstall TFS 11 Beta before or even after install of VS 2012 RC.

The Visual Studio RC has shown some install issues in some cases, particularly for those who upgrades from VS 11 Beta.  These issues are caused by also having TFS 11 Beta server installed on the same machine.  This is not a supported scenario.  What is good is that if you forget to uninstall TFS Beta 11 first, and get these issues, all that is required is to uninstall TFS 11 Beta, and VS 2012 RC will start working correctly!

I have listed the symptoms known now below, and will update if there are more issues.  Note that a repair will not fix the issue, and a Windows restore and subsequent reinstall may not fix it either.  The fixes below however, cures these issues, but you don’t have to do these now, just uninstall TFS 11 beta!

 

This forum post is about the same issues.

1. The Team Explorer Build node fails

When you try to access the Team Explorer Build node, you get a System.TypeLoadException error like this:

System.TypeLoadException: Could not load type 'Microsoft.TeamFoundation.Common.TfsBackgroundWorkerManager'

clip_image001

To solve this do as follows:

1. Open a command prompt as administrator

2. Go to your program files directory for VS 2012 and down to  the extension folder like:   C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\CommonExtensions\Microsoft\TeamFoundation\Team Explorer

3. Run “gacutil –if Microsoft.TeamFoundation.Build.Controls.dll

 

clip_image002

 

2. Accessing the Process node on Edit Build Definition fails

When you Edit a build definition and open the Process tab, it starts to load the custom assemblies (if you have any), then it stops before displaying the process parameters, with the messagebox : Team Foundation Error: Method not found: ‘System.String Microsoft.TeamFoundation.Build.Workflow.ProcessParameterError.get_ParameterValue()’

image

To solve this do as follows:

1. Go to C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\PrivateAssemblies

2. Run gacutil /if Microsoft.TeamFoundation.Build.Workflow.dll

3. The SQL Editor gives loading error

When you start up VS 2012 RC you get a loading error message.  The same happens if you try to go from the menu to  SQL/Transact-SQL Editor/New Query.

The ‘SqlStudio Editor Package’ package did not load correctly, or  The ‘SqlStudio Profile Package’ package did not load correctly, or The ‘Microsoft.VisualStudio.Data.Tools.SqlLanguageServices.Package’ did not load correctly.  You might even get all of these.

 

clip_image001

 

To solve this do as follows:

1. Open Control Panel/Programs and Features

2. Locate the “Microsoft SQL Server 2012 Data-Tier App Framework

    (Note , you might find up to 4 such instances)

clip_image002[5]

The ones with version numbers ending in 55 is from the SQL 2012 RC, the ones ending in 60 is from the SQL 2012 RTM.  There are two of each, one for x32 and one for x64.  Which is which no one knows.

3. Right click each of them, and select Repair.

(It would be nice if someone with this issue tries only the latest RTM ones, and see if that clears the error, and comment back to this post. I am out of non-functioning VS’s )

 

4.  Errors referring to some extension

You get errors referring to some extension that can’t be loaded, or can’t be found.  Check the activity log (see below), and verify there.  If you see yellow collision warnings there, the fix here should solve those too.

To solve these:   

1. Open a Visual Studio 2012 command prompt

2.  Run:   devenv /resetsettings

 

 

How to check for errors using the log

Do as follows to get to the activity log for Visual studio 2012 RC

1. Open a Visual Studio 2012 command prompt

2. Run:   devenv /log

This starts up Visual Studio. 

3. Go to %appdata%/Microsoft\VisualStudio\11.0

image

4. Double click the file named ActivityLog.xml. 

It will start up in your browser, and be formatted using the xslt in the same directory.

5.  Look for items marked in red. 

Example for Issue 1 :

image