Geeks With Blogs

News These postings are provided "AS IS" with no warranties, and confers no rights.
Locations of visitors to this page virtusa corp sharepoint virtusa.com shehan peruma
Shehan Peruma Administration & Configuration
Excel to SQL import error
Running the import wizard on my Windows 7 (64 bit) machine, to create a table by importing an Excel file, gave me the following error: the 'microsoft.ace.oledb.12.0' provider is not registered on the local machineTo fix this:Download and install the following: http://www.microsoft.com/do... ......

Posted On Wednesday, June 6, 2012 9:16 PM

Prevent anonymous access to form and application pages in SharePoint 2010
When you create a Publishing site that has anonymous access enabled, you will notice that anonymous users will not be able to access pages that reside in the “_layouts” virtual directory (e.g. http://siteX/_layouts/viewl... This is because the publishing infrastructure activates a hidden feature that prevents anonymous users from accessing these types of pages. However, if you were to create a site collection based of Blank Site Template, you would notice that these pages are accessible by ......

Posted On Tuesday, December 7, 2010 5:46 AM

Creating an anonymous site in SharePoint 2010
Here’s how: Open up the Central Administration site and click on “Manage Web Applications” under the “Application Management” section From the ribbon click on “New” (Note: if its an existing web app, then click on “Extend”) Fill in the fields with appropriate values. Under “Security Configurations” make sure to select “Yes” for “Allow Anonymous” Click OK Once the web application has been created, a site collection would need to be created. Navigate to “Application Management” –> “Create Site Collection” ......

Posted On Wednesday, December 1, 2010 5:05 AM

Exchange (Outlook) distribution list (mailing group) not showing up in SharePoint
This post is common knowledge to all SharePoint professionals out there, but for newbie's it can save hours of hair pulling (as I’ve got to learn from a bunch of people I’ve helped out) ;) Scenario: There is a distribution list you can see and use in outlook, but when you search for the same list in SharePoint it doesn’t show up in the people picker. What gives? Chances are that the distribution list is not security enabled. This would need to be done by your domain administrator. He would need to ......

Posted On Monday, October 12, 2009 2:38 AM

SharePoint not crawling links
We have a document library which makes use of the 'Link to a Document' content type which lets users add links to a document library. We noticed that users were using this feature to add links to documents hosted on sites outside of the SharePoint farm. This is all good as far as they are concerned because the content type does its job and end-user can access the external documents by clicking the link. However, we noticed that none of these links were showing up in the search results. When we looked ......

Posted On Monday, August 24, 2009 5:30 PM

A little 'gotcha' when restarting the search service
If you were to restart (i.e stop and then start) the search service, in a SharePoint farm, from the 'Services on server' page in Central Administration chances are that you might encounter both or either of the following errors when yo do a search on your web application: Your search cannot be completed because of a service error. Try your search again or contact your administrator for more information. The search request was unable to connect to the Search Service. This happens because after restarting ......

Posted On Thursday, August 20, 2009 12:15 PM

Invalid host file on index server when using a dedicated crawler
Incase you didn't know- when you set your index server to use a dedicated server for crawling, SharePoint updates the host file on the index server with the IP address of the WFE. However, there are times where SharePoint adds an invalid host entry when there are 2 or more WFE's. Example - Say there have 2 WFE's - MOSSWFE01 & MOSSWFE02. Setting MOSSWFE02 as the dedicated crawler will cause SharePoint to update the host file in the index server. It adds an entry for MOSSWFE01 with the IP address ......

Posted On Thursday, March 19, 2009 7:07 AM

Deploying Web Parts to farms with more than 1 WFE
If you're developing webparts using VSeWSS and going to run the setup.bat that that VSeWSS creates, you might need to modify the deploy solution line before running it. The deploysolution instruction that VSeWSS adds contains the -local argument. This is all good if you're going to run it on an implementation with only 1 WFE, but for farms with 2 or more WFE's then you will need to change -local to -immediate. I also make it a habit to call the execadmsvcjobs command before and after adding and deploying. ......

Posted On Monday, December 1, 2008 9:50 PM

Manually uninstalling WSS
Had a situation the other day where, after playing with the different installing options, WSS would not uninstall. Even running the repair option was of no help. Searching the net for solutions I came across this. Here are the steps I did: Disable and Stop the following services (If any): Windows SharePoint Services Administration Windows SharePoint Services Search Windows SharePoint Services Timer Windows SharePoint Services Tracing Windows SharePoint Services VSS Writer Backup and then delete the ......

Posted On Wednesday, July 23, 2008 3:04 PM

Search only items of a custom list
Had a requirement where search results should be limited to only items of a list. Naturally, I created a new Search Scope and set a rule of type Web Address to include the particular site holding the lists. Well...it did work, but not to my expectations. What was happening was that in addition to displaying the list items, the list views were also being displayed and so were other pages in the site....DOH! Doing a search on the net led me to this site. It was very informative, but it didn't provided ......

Posted On Wednesday, July 9, 2008 12:27 PM

Copyright © shehan | Powered by: GeeksWithBlogs.net