ThreadAbortException

Microsoft Expression

Microsoft Expression Blend 2.5 June 2008 Preview “The pre-release version of this product has expired. You must update to a newer release." Error

I have been running Expression Blend 2.5 June 2008 preview that targeted Silverlight 2 runtime and had not used it for a long time. When I tried opening it up last week, it threw the error “The pre-release version of this product has expired. You must update to a newer release” While there has been no Expression Blend 3 as per my knowledge, I didn't find a newer version of this 2.5 June preview as well, so was puzzled. Looked up the Expression site and their blog where they had a detailed post explaining ......