Microsoft Expression Blend 2.5 June 2008 Preview “The pre-release version of this product has expired. You must update to a newer release." Error

 

I have been running Expression Blend 2.5 June 2008 preview that targeted Silverlight 2 runtime and had not used it for a long time.

When I tried opening it up last week, it threw the error “The pre-release version of this product has expired.  You must update to a newer release”  While there has been no Expression Blend 3 as per my knowledge, I didn't find a newer version of this 2.5 June preview as well, so was puzzled.

Looked up the Expression site and their blog where they had a detailed post explaining this http://blogs.msdn.com/expression/archive/2008/09/25/expression-blend-2-sp1-preview-released.aspx 

It clearly states that the 2.5 June 2008 preview is no longer required and can be removed.  You just need to install Expression Blend 2 SP1 which has all the functionality and support for SL 2 that the 2.5 preview edition had.  Agreed, there is an amount of version naming confusion. 

So, if you are running Expression Blend 2.5 June 2008 or earlier preview, it is highly recommended to uninstall it and thereafter install the SP1 for Expression Blend from http://www.microsoft.com/downloads/details.aspx?familyid=EB9B5C48-BA2B-4C39-A1C3-135C60BBBE66&displaylang=en

For a list of FAQs on Expression Blend, check http://www.microsoft.com/expression/products/FAQ.aspx?key=blend

Cheers !!!

Print | posted on Friday, March 13, 2009 1:07 PM

Comments on this post

No comments posted yet.

Your comment:

 (will show your gravatar)