ASP.NET Webform’s DefaultButton to handle enter key

This is a video version of an article I had written earlier around handling enter key with the ASP.NET Webform’s DefaultButton property.  So its quite old and a feature of ASP.NET 2.0 but works fine with 3.5 version as well.

Note: In the master page scenario at the end of the video, the code this.form1.DefaultButton = Button1.UniqueID needs to come in the Page_Load event and not inside the button click event.  I just typed the syntax there.

Click here for a text version of this article

 

 

Cheers!!!

Print | posted on Friday, October 17, 2008 9:10 PM

Comments on this post

# re: ASP.NET Webform’s DefaultButton to handle enter key

Requesting Gravatar...
Very useful, Thanks :-)
Left by Rico on Nov 12, 2008 8:56 PM

# re: ASP.NET Webform’s DefaultButton to handle enter key

Requesting Gravatar...
very useful thank you
Left by Eman on Feb 22, 2009 1:08 PM

# re: ASP.NET Webform’s DefaultButton to handle enter key

Requesting Gravatar...
Very useful, Thanks you very much!
Left by testicular cancer symptoms on Apr 16, 2009 5:28 PM

# re: ASP.NET Webform’s DefaultButton to handle enter key

Requesting Gravatar...
Very thanks... this is show
Left by bstoll on Feb 05, 2010 2:05 AM

# re: ASP.NET Webform’s DefaultButton to handle enter key

Requesting Gravatar...
Thanks, Its working perfectly
Left by dnyaneshwar on May 03, 2010 8:00 PM

# re: ASP.NET Webform’s DefaultButton to handle enter key

Requesting Gravatar...
very very good
Left by meksika biberi zayiflama hapi on Jun 01, 2010 12:32 AM

# re: ASP.NET Webform’s DefaultButton to handle enter key

Requesting Gravatar...
Thanks, Its working perfectly
Left by العاب بلايستشن 2011 on Oct 31, 2010 11:28 PM

# re: ASP.NET Webform’s DefaultButton to handle enter key

Requesting Gravatar...
Excellent... this work very well. thanks a lot.
Left by Preetham on Jan 07, 2011 2:48 PM

# re: ASP.NET Webform’s DefaultButton to handle enter key

Requesting Gravatar...
I seem to get the same error message at our sales territory mapping office whenever I try to re-install SQL Azure. We are running Linux. Anyone else have that problem?
Left by Andrew on Jun 20, 2011 12:41 AM

Your comment:

 (will show your gravatar)