Geeks With Blogs

News My Blog has been MOVED to https://mfreidge.wordpress.com
Michael Freidgeim's OLD Blog My Blog has been MOVED to https://mfreidge.wordpress.com

A few times when I re-start debugging of my ASP.NET application from VS 2005 I received

"Unable to start debugging on the Web Server. The operation has timed out".

I had to restart IIS to fix the error. Not sure what causes this.

Posted on Tuesday, April 11, 2006 8:04 AM None | Back to top


Comments on this post: Visual Studio VS 2005 doesn't start debugging of Web Server.

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
Yeah I get that too. Attaching to the aspnet_wp process will still work though (at least it does for me). Hotkey is ctrl-alt-P then find aspnet_wp.exe and attach to it.
Left by Mark Cohen on Apr 17, 2006 9:07 AM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
I have all the problems mentioned above in additional i found out that on my development system if I press F5 to start the debugging process, the VS 2005 will wait endlessly until I "Alt-Tab" to switch to any other windows and then VS 2005 will start loading the debugging information. Some time i even get a "Time Out" for the debugging process to be started.
Left by Justnice on May 09, 2006 11:17 AM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
i got same error when i debug project first time
and when i try second time to debug it starts but first time gives timeout error after a long waiting....
Left by sadık on Jun 04, 2007 8:19 PM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
I too got the same problem and when I restarted the iis its works...
Thanks a lot... :)
Left by Rajapandi S on Jun 19, 2007 2:58 AM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
After reset IIS, it works fine
Thanks !! :)
Left by Amol on Oct 14, 2007 6:34 PM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
Did not start after iis reset too. Can anyone help?

First time, it gave me following error:
"The Web was created successfully, but an error occurred when trying to configure the application root for this web. Webs may not operate correctly without an application root."

After going through certain articles, I tried to fix some permissions on web root folder. I don't get that error now but I am still not able to debug my application.
Left by Chirag Bhagat on Nov 26, 2007 6:03 AM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
I got the same error. It was not resolved even after the IIS restart. I had to restart the machine to fix the error.

Left by Prabhat Joshi on Jan 28, 2008 10:38 AM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
Deleting the Virtual Directory and having Visual Studio recreate it by using the "Create Virtual Directory" button worked for me.
Left by Michael Logan on Mar 14, 2008 4:20 AM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
me too Reset IIS and it worked
Left by Aditya on Jul 31, 2008 3:38 AM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
i am having the same problem and when i press F5 to start debugging after creating a web site in my visual studio 2005 it says atl server does not support debugging i restarted IIS reinstalled IIS with XP service pack 2 problem persists
Left by soumya maitra on Sep 12, 2008 8:51 PM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
I have faced the similar problem after installing the VS 2005 Web Application project patch/plug in

I did the following steps
--------------------
In the Run Command window type "inetmger", press enter.
Select your virtual directory/web site.
right click and go to the Virtual directory tab.
Click on configuration button.
Go to Debugging Tab.
Check both the Debugging Flags "Enable ASP server-side script debugging"

It worked for me, but i'm sure my site was set these falg before. I dont know whether installtion of the plug in screwed up things.


Left by SR on Feb 27, 2009 4:08 PM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
hi ,
when i was debugging the project after build successful a message window is showing me that "Unable to debug on the web server .the operation ha timed out "


please help me that how can i rectify that error in my project .

thank u
dileep (9490971916)
Left by dileep kumar on Oct 03, 2009 1:31 AM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
Same problem for me , I restarted IIS and it works fime now.....


Thanks guys
Left by Parthiban on Oct 13, 2009 1:25 AM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
I also faced same problem. But I restart my IIS, and run aspnet_regiis -i. It was not enough, then I restarted my machine and it worked for me.
Left by Syed Tayyab Ali on Oct 20, 2009 1:41 PM

# re: Visual Studio VS 2005 doesn't start debugging of Web Server.
Requesting Gravatar...
i had the same problem.. iisresrt solved it...thanx
Left by ananya on Feb 10, 2010 1:00 AM

Your comment:
 (will show your gravatar)


Copyright © Michael Freidgeim | Powered by: GeeksWithBlogs.net