Geeks With Blogs

News
The Wrecking Bawl Destructuring query language, one keyword at a time.
I was getting the error below when trying to deploy to my SQL 2008 R2 cluster, which was odd since I had never had any trouble before.  The problem ended up being that when I double clicked on the SSISDeploymentManifest file my computer was using the SQL 2012 version of the deployment utility because I had recently installed it.  Once I used the 2008 utility everything worked fine.

Exception details: Microsoft.SqlServer.Dts.Runtime.DtsRuntimeException: Storing or modifying packages in SQL Server requires the SSIS runtime and database to be the same version. Storing packages in earlier versions is not supported.
 ---> System.Runtime.InteropServices.COMException: Storing or modifying packages in SQL Server requires the SSIS runtime and database to be the same version. Storing packages in earlier versions is not supported.
Posted on Monday, May 20, 2013 11:13 AM all tech stuff , SQL Server | Back to top


Comments on this post: ssis error deploying package

# re: ssis error deploying package
Requesting Gravatar...
Hello,

How did you change it to use the SQL Server 2008 utility?

Regards,
Sankalp
Left by Sankalp on Mar 31, 2015 5:50 AM

# re: ssis error deploying package
Requesting Gravatar...
Right click on the file and select "Open with" and point to the 2008 executable (whatever the 2008 version of the below exe is).

From the command prompt, run isdeploymentwizard.exe from %ProgramFiles%\Microsoft SQL Server\110\DTS\Binn. On 64-bit computers, there is also a 32-bit version of the tool in %ProgramFiles(x86)%\Microsoft SQL Server\100\DTS\Binn
Left by Alex on Mar 31, 2015 5:55 AM

Your comment:
 (will show your gravatar)


Copyright © Alex Bransky | Powered by: GeeksWithBlogs.net