AJAX Control Toolkit Controls Grayed Out - HOW TO FIX

Spent the weekend so far using the new release of Visual Studio 2008 and ASP.NET AJAX. More specifically, I have been using the ASP.NET AJAX Control Toolkit. Adding the new controls to your VS2008 toolbox is a straight-forward process, but when I added them - at first everything was fine - but after a few hours they seemed to magically disappear.

Trying to add them again didn't seem to do anything at all as nothing changed. Right-clicking on the VS2008 toolbox and selecting Show All actually did give me the AJAX controls back in the toolbox (they really never left) BUT - they were all grayed out and I was unable to use them in any of my ASP.NET projects.

AJAX controls error

I tried deleting this group and even reset my entire toolbox - but nothing seemed to change it back. After a bit of wrangling, these are the steps I used to get around the problem (using Windows Vista).

1) Shut down Visual Studio 2008

2) Go to your Task Manager and make sure that the dev.exe process is NOT running. If it is, end the process.

3) Go to C:\Users\[user]\AppData\Local\Microsoft\VisualStudio\9.0 and delete all the .tbd files. There will be four of these files. If you can't seem to navigate to this folder, you will have to go to your Folder options and enable it to see all hidden files and folders.

4) From there, open up Visual Studio 2008 and re-add the group and the controls to your toolbox.

To tell you the truth - I had to run through these steps twice before it actually worked. Not sure of the reason for that - but it worked in the end.

«November»
SunMonTueWedThuFriSat
28293031123
45678910
11121314151617
18192021222324
2526272829301
2345678