Geeks With Blogs

News

Subscribe in NewsGator Online

Thawte WOT Notary
Serving Southern Indiana



Eric Hammersley <insert impressive list of technology to blog about here>

In my initial post on Installing Vista Beta 1 on VMware v5 build 13124 - Initial Observations I was able to get all the VM hardware to work except the sound card.  The native VMtools provided sound driver just wouldn’t install.  If you look at the sound device in other “working” VMs, like an install of Windows XP, you’ll see that the VMware hardware emulates a Soundblaster PCI.  I’m not sure why I didn’t think of this before but I went to the Soundblaster site and downloaded their Soundblaster PCI 128 driver myself.  To avoid the crazy navigation on their site I’ve linked to the agreement screen of the driver you need.  Download from Creative: Soundblaster PCI 128

I thought about repackaging the driver so it would be a clean install but I don’t want to violate their licensing agreements as far as packaging their driver is concerned.  With that said you’ll have to deal with their installer… but it does work!

Posted on Sunday, July 31, 2005 12:15 PM Software , Windows Vista | Back to top


Comments on this post: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
Thanks for all the information!
Left by Sergio on Aug 01, 2005 5:42 AM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
Well, I get the bluescreen on Vista Beta 1 after installing this driver. Before I installed it, I installed the rest of the VMware tools manually. So I had video and network working, everything except sound. And now I get a PFN_LIST_CORRUPT bluescreen error.

If someone has a solution to this, it would be nice with a post.
Left by Atle on Aug 01, 2005 5:44 AM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
One time coinsidence. The next time I installed Vista Beta 1, there was no problems when installing the sound drivers after everything else. Just remember to take a snapshot before running this setup.
Left by Atle on Aug 01, 2005 11:36 PM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
Excellent, glad to hear it!
Left by Eric Hammersley on Aug 02, 2005 6:53 AM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
I installed the driver but I have a "blue screen of death" :s
Left by marcel on Aug 02, 2005 12:29 PM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
Others have had this problem. Most fix it by starting over and installing the sound driver right off the bat. The person two comments up had the same problem and fixed it by reinstalling and installing the sound driver after first boot.
Left by Eric Hammersley on Aug 02, 2005 12:42 PM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
I was unable to install the Sound Driver the First time, it said it could not detect the hardware. So I went into properties, Comapatibilty tab, and Chose Windows XP.
I also Checked Run as administrator though that probably was not needed.
The software installed fine and promted for a reboot. Sound Good!
Left by William on Aug 18, 2005 11:47 AM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
Yes, that last one is a golden hint!
Running programs in compatibility mode is great.
But my sound isn't great.
A lot of noise
Left by photubias on Aug 19, 2005 12:58 PM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
thank you

pansueb@yahoo.com
Left by pansueb@yahoo.com on Oct 09, 2005 7:03 AM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
Hi, i just would like to tell that this also worked for me.

Im running VMware 5.5 RC Build 16958 with Vista Pre Beta2 build 5231.

I have a Soundblaster Audigy 2 ZS sound card btw.

Thanks.
Left by goa2goa on Oct 13, 2005 10:11 PM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
PS. There was no need for me to run in compability mode or do anything special. Just run the installer.

Only thing is that after installing the driver and rebooting, VMware stilled showed the closing screens even if it was rebooting.

I just reset WMvare and started up in normal mode. I think actually it is just a bug in VMware and not related to the sound driver install at all.
Left by goa2goa on Oct 13, 2005 10:15 PM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
driver wouldn't install on Vista 5270 :(
Left by Raph on Jan 21, 2006 2:42 AM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
I have build 5342 and it will not install the driver, I have no sound I also cant install items such as MSN beta and yahoo games that I can tell righ now.
my sound card is a VIA AC'97 Enhanced audio contoller and it is "working properly" but I still have no sound. any help would be great.

Thanks for your time
socalhazard@gmail.com
zreodark@hotmail.com
Left by Bullfrog on May 16, 2006 6:31 AM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
Got to thank you for this. Been messing with various drivers and stuff for months. With the Soundblaster PCI 128
drivers you linked to, it's fine. VMWare 4.52. Vista Business.
Left by Peter on Dec 17, 2007 10:57 AM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
When I try SoundBlaster PCI 128 driver installation in Windows XP, it is asking for some driver files in windows/system32/drivers/, I am not having these files in VMware windows 2003 server. Could Please guide me how to complete the PCI 128 install in Windows XP or better we should use Creative sound card only for the audio to work in Windows System.
Left by Bala on Mar 18, 2008 7:17 AM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
Worked like a charm, especially for a vista lite version in vmware. Brilliant quality for a virtual machine, thanks!!
Left by Jon on Jul 24, 2008 12:34 PM

# re: Windows Vista Beta 1 - Sound support with VMware v5 build 13124 without VMtools
Requesting Gravatar...
Very good post. I appreciate the work you guys put in to make this world a better place for the disabled. Thanks…
Left by tiffany on Aug 01, 2009 8:08 AM

Your comment:
 (will show your gravatar)


Copyright © Eric Hammersley | Powered by: GeeksWithBlogs.net | Join free