Geeks With Blogs

News


Edmund Zhao's BizTalk abc We share, We learn

I received a very unusual error message few days ago when I configured a secondary BizTalk Server to join an existing server group (BizTalk 2004). The error message said "The BAM Primary Import Database registered in the BizTalk Management database is not compatible with the currently installed version of BizTalk Server." It happened only when I added the server to this particular server group, there was no error when I chose to join other server groups. Apparently something was wrong in the configuration of this group.

Before taking action to re-configure the master BizTalk server in that group (of course, all BizTalk applications also need to be redeployed), I checked the database carefully. I found the table "BizTalkDBVersion" in BAM Primary Import Database was empty. So I decided to give a try by manually insert a record into this table. I grabbed the version parameter from corresponding tables on other servers, and inserted a record. After all, the BizTalk configuration allowed me to use this Management batabase!

This helped me to understand the role "BizTalkDBVersion" table plays in each BizTalk databases.

...Edmund Zhao  

 

Posted on Tuesday, February 13, 2007 10:56 AM | Back to top


Comments on this post: Database is not compatible with the currently installed version of BizTalk Server

No comments posted yet.
Your comment:
 (will show your gravatar)


Copyright © Edmund Zhao | Powered by: GeeksWithBlogs.net