D'Arcy from Winnipeg
Solution Architecture, Business & Entrepreneurship, Microsoft, and Adoption

Adventures in WP7 – Pin To Start Image Madness!!!

Wednesday, October 27, 2010 12:06 PM

One of the items I got hit with in my initial WP7 app rejection was that my “Pin-To-Start image didn’t match with the rest of the icons”. Hmm, come to think of it I never did test that.

So I tried it out. To pin an app, you hold down until you get the menu below, then you pin it to the start screen.

image

After I did this, I saw a big blue box where my app logo should have gone. So that’s what they were talking about.

image

Now, my image is set in my project’s properties page…

image 

…but maybe because I was messing around directly with the WMManifest.xml file, I needed to put back some of the properties that I had removed previously when I was getting a weird “can’t find your image” error. So I reverted from this…

image

…back to this…

image

*Note: If you’re curious what the TemplateType5 tag is about, check out Rudi Grobler’s blog post where he explains all the different Template Types.

Even reverting the setting in the URL didn’t fix things. Well WTF…

It turns out the culprit to all this was the Build Action for my PNG file.

image

Adding it defaults to Resource, but for the purposes of the Pin-To-Start tile image, you just need to switch it to Content instead.

Voila! Ok, app is re-submitted. No whammies, no whammies…




Feedback

# re: Adventures in WP7 – Pin To Start Image Madness!!!


My guess that if you tried Embeded Resource it would work as well. From the name I would expect the image to be compiled into the actual app.

Just a thought...

- wd 10/27/2010 1:12 PM | William Highfield

# re: Adventures in WP7 – Pin To Start Image Madness!!!

You'd think so, right? But it actually doesn't work. I switched it to Embedded Resource, and flipped the bool values in the xml tag attributes (so relative to false, is resource to true). I get a pixelated version of the Windows blue ring of waiting.

I tried some different combinations, but Content is the only one that properly displays the graphic when pinning it to the start menu.

Weird eh?

D 10/27/2010 3:20 PM | D'Arcy from Winnipeg

# re: Adventures in WP7 – Pin To Start Image Madness!!!

Alternatively.. you can have set IsResource=true and it would have worked.. 2/12/2012 11:55 PM | Mohib Sheth

Post a comment