Analysis Services 2008 Performance Counters showing zero

I had an issue recently with my SSAS 2008 performance counters - they were all showing up as 0. I could see them listed in Performance Monitor, but none of them worked. The counters for my SSAS 2005 instance worked fine, but the 2008 ones did not.

I had observed this behaviour on my old Vista x86 machine and now it was happening on a fresh install of Windows 7 x64.

I tried numerous steps to troubleshoot this issue including going through this detailed blog post from the CSS SQL Server Engineers blog, but I still could not fix this issue.

It was actually a forum post about issues someone was having with IIS counters that put me onto the right track. Apparently you can have issues with performance counters due to the permissions of the account that the service is running under.

I was running my SSAS 2008 service as Network Service, changing it to run as LocalSystem fixed my issue and now my SSAS 2008 performance counters are working.

I'm sure that this could also be fixed by manipulating the permissions of the files under
"<%Program Files%>\Microsoft SQL Server\MSAS10<.Instance Name>\OLAP\bin\Counters"
but for the time being this solution is sufficient for my needs. :)

Print | posted on Sunday, November 22, 2009 11:22 PM

Comments on this post

# re: Analysis Services 2008 Performance Counters showing zero

Requesting Gravatar...
Thanks for the tip.

Alex Rosa
http://www.keep-learning.com/blog
Left by Alex Rosa on Nov 23, 2009 10:56 AM

# re: Analysis Services 2008 Performance Counters showing zero

Requesting Gravatar...
Just to add to this.

I had a similar issue last year. I was trying to analyse some performance issues on few SSAS servers.While creating Counter log, I found that counters were not getting stored in the output csv on few of the instances.

Just to give you a little background on the environment config. All the servers are Windows 2003, and SSAS 2005 windows services runs under a common service a/c.

So later, I used the same service a/c credentials for each counter logs, and to my surprise it worked, this service accounts n security is always a shaky ground for me.

Left by Sumit Khemka on Oct 18, 2010 6:45 AM

# re: Analysis Services 2008 Performance Counters showing zero

Requesting Gravatar...
Here are this and some other articles on Profiler, SSAS Server Trace and Performance Counters:
http://ssas-wiki.com/w/Articles#Profiler.2C_SSAS_Server_Trace_and_Performance_Counters
Left by Sam Kane on Mar 19, 2011 7:29 AM

Your comment:

 (will show your gravatar)