Geeks With Blogs

News
Charles Young

First posted at charlesyoung.joeuser.com 25th March 2004

I had a problem yesterday with Visual Studio .NET. I was attempting to debug a .NET web application hosted on a non-default local website using host headers. Every time I tried to run the project I got a message saying that the current user was not a member of the 'Debugger Users' group. Suffice to say that, of course, the current log-on account was a member of this group. At one point I went as far as adding every available local and domain account to the group in a vain attempt to try to work out way I was getting the message - nothing helped.

Eventually, by trial and error , a colleague and I worked out that we needed to add the site to the 'trusted sites' zone and the lower the security settings for trusted sites using IE options. I don't know why this worked, or why I got the message I did from Visual Studio, and unfortunately I don't have time at present to dig deeper.

Posted on Tuesday, April 13, 2004 11:52 AM | Back to top


Comments on this post: Visual Studio debugging on a non-default local web site

# re: Visual Studio debugging on a non-default local web site
Requesting Gravatar...
As a side note... if you're working on a site hosted on the same box, by default the site is considered an 'intranet' site. My problem was that, for security reasons, I had set all zones to 'prompt for password'. For Intranet, you must set it to automatic login or you'll get another vague error message that makes absolutely no sense in it's context.
Left by nausea on Apr 05, 2005 6:04 PM

Your comment:
 (will show your gravatar)


Copyright © Charles Young | Powered by: GeeksWithBlogs.net