Geeks With Blogs

News
Anirudha gupta

I have write How to run PHP in Webmatrix ? few months ago. In this post I will try to explain it little bit better.

When you create a website in webmatrix then try to go to  site > settings > here you can find the option for enble the PHP for your website on IIS express.

11

You can also install the PHP through WPI (web platform installer). The PHP you have installed will be going into C:\Program Files (x86)\IIS Express\PHP/$

$ = version of PHP you have installed.

Try http://forums.iis.net/1166.aspx for any help regarding installing PHP in webmatrix. you can post your idea also to webmatrix.uservoice.com

Posted on Tuesday, November 13, 2012 1:01 PM | Back to top


Comments on this post: How to run PHP in Webmatrix (updated) ?

# re: How to run PHP in Webmatrix (updated) ?
Requesting Gravatar...
Hello,

I am trying to work with PHP on Webmatrix
I opened empty new site but when I run it I just get in the IE browser a message the page can't be displayed.

I installed PHP version5.3 that was installed well but
I got a notice that Drivers for PHP wasn't installed
I tried to download and install from MS website
but it didn't work well.

I read in one website that I need to edit PHP.ini but I couldn't edit it and save.

Any help will be great.

Regards,
Tomer
Left by Tomer on Jan 31, 2014 5:46 PM

# re: How to run PHP in Webmatrix (updated) ?
Requesting Gravatar...
You need to register your PHP installation in IIS Express to run them in webmatrix. If you don't want to do that simply install the PHP through WPI.

WPI will fix all those issue when you just make a wordpres installation (just make it so it will configure everything then delete it).

for fix PHP look at http://stackoverflow.com/questions/10260691/php-not-worked-in-iis-express-when-wordpress-run-with-no-issue
You can contact the webmatrix team at webmatrixatmicrosoft.com or make a thread on forums.asp.net or webmatrix forum at IIS.net

Thanks
Gupta
Left by Anirudha on Feb 01, 2014 11:54 AM

# re: How to run PHP in Webmatrix (updated) ?
Requesting Gravatar...
I have installed php5.6 via WPI.
In Webmatrix Site - Settings - PHP Settings i have activated php. I only can choose PHP 5.3 or PHP 5.4 or PHP 5.5, but not php 5.6. Why?
Thanks for an answer.
Left by Herbert Toifl on Feb 23, 2015 11:04 PM

Your comment:
 (will show your gravatar)


Copyright © Anirudha | Powered by: GeeksWithBlogs.net