Geeks With Blogs

Tim Huffam Dotting the I and crossing the T of I.T. July 2008 Entries
How to find out what the client (browser) is posting back to the server (with ASP.NET C#)
For those of you wanting to know just what is being sent (posted) back from the client (browser) to the server (ASP.NET) - when a postback occurs - use the following lines in your C# ASP.NET program: string msg = ""; for (int i = 0; i < Request.Form.AllKeys.Length; i++) { msg += i.ToString() + " " + Request.Form.GetKey(i) + ": " + Request.Form[Request.Form.G... + "\r\n"; } System.Diagnostics.Debug.Wr... Either look at the output window or put a break-point on the last line so you ......

Posted On Thursday, July 24, 2008 1:43 PM

Agile Manifesto - addendum 0.1

Fresh chocolate chip cookies and fresh coffee over garden variety cookies and instant coffee

That is, while there is value in the items on the right, we value items on the left more.

The unspoken rule is that non-team members attending team meetings must come bearing the fore mentioned items

Posted On Wednesday, July 23, 2008 1:58 PM

Web development client side debugging - display area, javascript injection and accessing the dom at runtime
For those of you who don't have access to IE or FF dev toolbars - this is how we used to do client side runtime debugging... Drop the following code into your web page (preferrably at the bottom): <script> function log(text){ document.getElementById("lo... = text; } function dump(){ log(document.body.innerHTML); } function logProps(obj){ var msg = ""; for(var i=0;i<obj.attributes.len... { msg+=obj.attributes[i].node... + ": " + obj.attributes[i].nodeValue + "\r\n"; } log(msg); ......

Posted On Friday, July 11, 2008 10:52 AM

ASP.NET 3.5 controls not being rendered
For some reason some controls/tags within ASP.NET do not always get rendered/passed to the client. This has happened to me on a number of occasions. It seems limited to <style> and <script> tags - but happens for both raw HTML (within the aspx designer) and dynamically created tags (eg using new HtmlGenericControl("style")... This is happening to controls/tags within AJAX updatepanels within, webforms and usercontrols. Sometimes I can work around this by simply placing these controls/tags ......

Posted On Wednesday, July 9, 2008 10:50 PM

Javascript error using Telerik controls with ASP.Net: Error: 'Telerik' is undefined
The following javascript error occurs when trying to use the Telerik controls and you haven't updated your ASP.NET (2.0) web.config file correctly. Error: 'Telerik' is undefined To fix make sure the following lines are within the <system.web> section of your web.config file: <httpHandlers> <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.S... System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad36... validate="false" ......

Posted On Wednesday, July 9, 2008 9:03 AM

Scuttle import bookmarks not working
With a clean install of Scuttle I found that both the import bookmarks pages (importNetscape.php and import.php) do not work - instead the both display the source of the PHP files. This is caused by both files not having the correct php declaration at the beginning of the file eg -both of these files first line was: <? However they should have been: <?php So just simply update these files. HTH Tim ......

Posted On Friday, July 4, 2008 12:14 PM

Scuttle throwing PHP errors: Passing locale category name as string is deprecated. and Invalid locale category name LC_MESSAGES, must be one of LC_ALL,...
I got the following error on a fresh install of Scuttle (0.7.2) on a newly created Windows Server 2003 with PHP (5.2.6), MySQL5.0.51b) and IIS 6: Warning: setlocale() [function.setlocale]: Passing locale category name as string is deprecated. Use the LC_* -constants instead in C:\Inetpub\Scuttle\includes... on line 131 Warning: setlocale() [function.setlocale]: Invalid locale category name LC_MESSAGES, must be one of LC_ALL, LC_COLLATE, LC_CTYPE, LC_MONETARY, LC_NUMERIC, or LC_TIME ......

Posted On Friday, July 4, 2008 8:15 AM

Getting PHP 5.2.6 and MySQL (and PHPMyAdmin) working on IIS 6 Windows 2003 Server
It seems every time I try to install PHP and MySQL something doesn't work - usually there's either a file missing from the PHP distro or something in the install notes is missing or incorrect. This time it was both. I first tried the PHP msi install - first mistake. As it does not include the MySQL extensions - neither does the 5.2.6 PECL zip file (I mistakenly thought this would include all the extensions). So if you've installed PHP using the MSI installer - uninstall it (via Control Panel - Add/Remove ......

Posted On Wednesday, July 2, 2008 9:18 AM

Copyright © Tim Huffam | Powered by: GeeksWithBlogs.net