Geeks With Blogs

Tim Huffam Dotting the I and crossing the T of I.T.

This error:

Microsoft .NET Framework 3.0 has encountered a problem during setup. 
Setup did not complete correctly.

occured while installing the .NET 3.0 redistrubutable (downloaded from here) on my PC running XP Pro SP (also with .NET 1.1 & 2.0).

After some investigation it turns out this error was caused when installing the WCF (Windows Communication Foundation) components - when trying to open the following registry key:

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Security\ServiceModel 3.0.0.0

I thought this was odd, because my user is a local admin - so in regedit (regedt32) I tried giving my user permissions to full control of this registry node... then reran the install - however to no avail - same error.

So, tried giving Everyone full control of this node - reran the install - and bingo, it worked!

For those of you who don't know - here's how:

  1. Open the registry editor: Start - Run..., then enter "regedt32" (without quotes). 
  2. Navigate down to the node by opening each node in the heirarchy.
  3. Right click on the node we're after (ServiceModel 3.0.0.0) and select Permissions
  4. Click on Add, then enter "everyone" (no quotes) on the 'Select Users, Computers or Groups' dialog then click OK.
  5. Back on the 'Permissions for ServiceModel 3.0.0.0' dialog select the user group Everyone, then make sure the Full Control checkbox has a tick, then click OK.

Thats it - now rerun the .NET 3.0 installation.

HTH

Tim

Posted on Friday, November 17, 2006 9:28 AM C# .NET , ASP.NET | Back to top


Comments on this post: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Thanks for the great help to someone like me who only knows kicking the chair when a program fails. You might want to follow up with a post titled "Troubleshooting Microsoft Installation Programs for Dummy". Thanks again.
Left by Yang on Nov 22, 2006 1:30 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Thanks Tim. It worked for me too :-)
Left by Andy on Jan 05, 2007 11:28 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Not working for me. I don't see that "ServiceModel 3.0.0.0" key anywhere. i did a search and can't find it. I tried to open up permissions to the whole Eventlog key without avail. any ideas?
Left by scottb on Feb 26, 2007 2:39 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
no available ServiceModel 3.0.0.0 for me too
Left by dotnetter on Feb 27, 2007 3:56 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Cannot see the "ServiceModel 3.0.0.0" key anywhere.
:-(

Need to install 3.0 very badly.
Any further HELP!!

Thanks,
zullu
Left by zullu on Jun 15, 2007 3:45 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Just set permission to everyone when you right click on the main folders. Worked like a charm for me!

-Thanks TiM!
Left by Max Doe on Jul 17, 2007 9:07 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Hi guys,
Can someone help me.

I facing a problem when install Microsoft .Net Framework 3.0 on Windows Server 2003 SP2. Setup could not download all of the necessary files.

FYI, I already install .NET Framework 2.0. I logon using administrator account to setup .NET Framework 3.0 but doesn't work.

Thanks,
Jon
Left by jon on Sep 06, 2007 4:13 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Cannot see the "ServiceModel 3.0.0.0" key anywhere.

This is a Windows XP desktop with latest patches and service patches. Need help very badly.
Left by Nen on Oct 25, 2007 3:51 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Thru countless times of trying to uninstall, reinstall, then uninstall again only winding up reinstalling all versions of Framework AGAIN, that STILL doesn't work! ...Should we have to do this, I mean every version of recent Windows operating system software is at least $200.00, don't you think that they should apply updates that actually work??? And I really don't think that it should take literally months either to correct this. What is really aggravating is that some programs WON'T install unless this version is installed!! I can't believe that they would release this and allow the release to software distributors such as Roxio without correcting at least the "install" bugs first!!!!
Well, after some more hours research on this, I found this site from msdn.com that might "fix" this:

http://blogs.msdn.com/astebner/archive/2006/09/04/739820.aspx

I am trying this now as we "speak" so to say. Who knows, it might work.

Left by Ann on Oct 26, 2007 12:31 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
i m facing problem when i try to insall dotnet framework 3.0 in windows xp and not able to solve he problem
Left by dhanesh on Nov 17, 2007 7:53 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Main folder?

Tim you say to set permissions to everyone when you right click on the main folder?
what in the name of blazes is the main folder?
Left by charles on Dec 20, 2007 11:40 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Sorry, but you guys need to learn using the registry...
He is pointing you directly to the f***ng "ServiceModel 3.0.0.0" key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Security\ServiceModel 3.0.0.0
Left by Eugen on Jan 25, 2008 6:55 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Thanks for the tip on the reg key permissions. It was a lifesaver. I had a failed install of the boostrapper .NET 3.0, and thought I was screwed since the full download setup wouldn't complete. This fixed it though.
Left by adam on Feb 05, 2008 1:39 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Eugen, you need to lighten up.

I do know how to use the registry, and I definately DO NOT have a ServiceModel 3.0.0.0 key in the location referenced. However, on other PCs in my environment, this key is present.

So, now the question is why is this not present on 2 of my PCs when it appears in all others. There shouldn't be any difference.
Left by bdn on Feb 07, 2008 10:34 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Cheers worked a treat
Left by Damian on Feb 14, 2008 8:48 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Damn, this won't work for me, I can't find that file or whatever in the first place, and even when I changed the security permissions or whatever it still didn't work... Man, I need this bad, gotta install Sony Vegas :)
Left by Dom on Mar 18, 2008 9:30 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
i fixed that it still wont complete the download could some one please help me sony vegas 8 or other programs wont run without this =/ u said go 2 registry and go 2 service model 3.0.0.0 i did then i right clicked went to permission hit add and under enter the object names to select i put everyone ticked full control reran the installation and it didnt work...help please?
Left by ademar on Mar 28, 2008 7:49 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
i did everything here and still won't install.
Maybe i have a different error that doesn't have to do with this.
Thanks anyways and happy those who got it working
Left by esdfd on May 25, 2008 6:41 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
I think I got lucky folks, but use Windows Install Clean Up (download from Microsoft) to get rid of 1.0 and 2.0 and whatever .NET framework packages you have installed.

From the beginning, install 1.0 distributable, then 2.0 distributable again... then install .NET Framework 2.0 SP1 (x86) from here: http://www.microsoft.com/downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-A7633F706BA5&displaylang=en

After installing that, download and install .NET Framework 3.0 Service Pack 1 (NOT THE DISTRIBUTABLE PACKAGE). You can find it here:
http://www.microsoft.com/downloads/details.aspx?familyid=EC2CA85D-B255-4425-9E65-1E88A0BDB72A&displaylang=en

Worked a treat for me! =]
Left by Director Dash on Jun 11, 2008 3:59 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Please refer Microsoft .NET Framework 3.0 Release Notes http://msdn.microsoft.com/en-us/windowsvista/bb188202.aspx#topic3
Left by Eric on Sep 02, 2008 6:00 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Worked for me too.

BTW, the log file which led me to the error was generated in the %temp% directory, it had a line:
Product: Windows Communication Foundation -- Error 1402.Could not open key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Security\ServiceModel 3.0.0.0. System error 5. Verify that you have sufficient access to that key, or contact your support personnel.

Which led me to your blog, and the permissions setting. Thanks.
Left by rax on Sep 12, 2008 4:45 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Thanks you are help me instaling nokia Pc suite
Left by PROVIDUR on Oct 04, 2008 9:48 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Your steps work for me.. thank you so much... keep a good work.
Left by cia on Nov 01, 2008 6:33 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
i am installing the above software and in the middle of installation,a message box is displayed that "setup cant continue",somewhat of this type only...please help me.
Left by ankit on Nov 15, 2008 3:27 PM

# re: Error installing .Net 2.0 sp1(x86): Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
the software runs and at the middle,it gets stop and a dialogue box appers which displays,setup cant continue,if you are at the middle,data can be lost,,,what to do,please help me!!!!
Left by ankit on Nov 15, 2008 3:47 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Steve Walsh's instructions worked for me:

# Mr 1/24/2008 12:02 AM Steve Walsh
Okay, I grappled with not having a "ServiceModel 3.0.0.0" entry. So I did this and it worked: In the registry navigate as per the instructions above and right click on the Eventlog/Security folder. Select "Permissions". Select "Administrators" and click so there is a tick in all "Allow" boxes and then do the same for "Systems". Click "OK" to close the Permissions for Security dialog and close Regedit. Now try and install.
Left by Lou on Nov 19, 2008 8:58 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
"Sorry, but you guys need to learn using the registry...
He is pointing you directly to the f***ng "ServiceModel 3.0.0.0" key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Security\ServiceModel 3.0.0.0"

Effin' troll.
Left by Gandalf on Dec 02, 2008 2:14 PM

# re: this fix worked for me
Requesting Gravatar...
I am installing Paint.Net and it recommends installing with dot.net framework 3.5 SP1.

Then when i run it, it says cannot install without windows installer 3.1. So i downloaded and ran that fine.

So when i went back to run dot.net 3.5 SP1 it said:
"a problem has occured while installing set up component"

I came here, tried the fix, but couldnt see the service model key in my operating system (XP PRO SP2). I tried setting the permissions on the Security folder to allow access to everyone but it didnt work, same error window popped up.

Just by accident I remembered I had a file downloaded from a previous program that was called dotnetfx.exe, so i thought what the hey and ran it, it turned out to be dot.net framework 1.1 - which installed fine.

Then I ran dot.net 3.5 again and it installed fine and now it's downloading the installation package from the net.

So incase this works, my steps were:
run windows installer 3.1
run dotnetfx version 1.1
run dot.net 3.5 SP1

hope this helps
Left by anon on Dec 02, 2008 8:03 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Hi, I had the same problem, I tried the above method with no luck. I solved it by directly jumped to .NET 3.5 instead of 3.0. Here is the link:
http://www.microsoft.com/downloads/details.aspx?FamilyID=333325fd-ae52-4e35-b531-508d977d32a6&DisplayLang=en

Hopefully the link is still there, I can't understand why Microsoft keeps changing their content's link. I had seen too many times a link doesn't exist anymore, and was brought to another not exist address.

HTH
Left by Raymond on Dec 25, 2008 5:12 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
now I'm no code computer expert but a a good couple of days of searching & trial and error have lead me to this answers.

1. Go to start menu, then Run
2. Type in cmd
3. Copy and paste all of this to the prompt menu and press enter for each box....

regsvr32 /u softpub.dll
regsvr32 /u wintrust.dll
regsvr32 /u initpki.dll
regsvr32 /u dssenh.dll
regsvr32 /u rsaenh.dll
regsvr32 /u gpkcsp.dll
regsvr32 /u sccbase.dll
regsvr32 /u slbcsp.dll
regsvr32 /u mssip32.dll
regsvr32 /u cryptdlg.dll
exit

THEN

Copy and paste all of this to the prompt menu and press enter for each box....

regsvr32 softpub.dll
regsvr32 wintrust.dll
regsvr32 initpki.dll
regsvr32 dssenh.dll
regsvr32 rsaenh.dll
regsvr32 gpkcsp.dll
regsvr32 sccbase.dll
regsvr32 slbcsp.dll
regsvr32 mssip32.dll
regsvr32 cryptdlg.dll

worked for xp sp2.....dam i love the interweb
Left by Cuban B on Feb 06, 2009 7:08 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
I get error code 1601:
1601 - ERROR_INSTALL_SERVICE_FAILURE
The Windows Installer service could not be accessed. Contact your support personnel to verify that the Windows Installer service is properly registered.

I tried to download Windows Installer, I got another error message:
The application failed to initialize properly 0xc0000142. Click on OK to terminate the application.

I've already tried everything that everyone posted, but I can't install .Net 3.0, which means I can't access my cd/DvD burner.
Left by Wes on Mar 02, 2009 8:53 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Ok, I've been plugging away for hours now, and finally found that .Net 3.5 will install, even though 3.0 & 3.1 won't.

I went to Windows Update & now I'm about to reboot. Let's see if I can get my burners going.
Left by Wes on Mar 02, 2009 1:42 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Hi Friends,

I tried some of the above solutions to fix the problem, but still it shows the error "Microsoft .NET Framework 3.0 has encountered a problem during setup. Setup did not complete correctly"

Here is the error report:

EventType : wap10setup P1 : 13165 P2 : 3.0.04506.30_waprtm_x86_sfx
P3 : gen P4 : inst P5 : f P6 : dlmgr_bitserror P7 : -2147012889
P8 : 0 P9 : runtofinish()_failed to retrie P10 :

The error report contains:
F:\DOCUME~1\Admin\LOCALS~1\Temp\WLF52.tmp
F:\DOCUME~1\Admin\LOCALS~1\Temp\SDB53.tmp
F:\WINDOWS\system32\BITS.LOG

Any idea to solve this..

Left by Gaurav on Mar 05, 2009 7:37 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
I've been trying to install new framework 3.x for the last month. My system is XP-Pro fully patched through SP3, quad core, 4 gbyte memory, lots of disk space.

I've also tried the instructions that said to uninstall all versions of .net and start over. Done that via the uninstaller download tool.

I've got v1, v1.1 v2.0 framework etc all installed and patched just fine. System is very stable.

I gave up with downloading via the update site and downloaded the v3 redistributable package.

Symptoms are **always** the same. Never change. I start the installer, it unpacks the files, enters setup and it looks to hang at about 30-40% through. Fatal system hang, to get back into XP I need to boot into safe mode and do a system restore. Every time. There don't appear to be any errors in the log files in my temp directorys.

However the last entry in one of the logs mentions that its messing with the fonts. After the crash and restore, just opening the font directory produces a fatal error, either via explorer or by the control panel.

I found that deleting the fonts that started with global* via a cmd prompt window cleared that problem.

I've been chasing blogs, tech notes, MSDN articles etc for the last month. I'm pretty much at my wits end.

Anyone out there have any advice, I'd sure appreciate it.

Thanks

Left by lfdal54 on May 05, 2009 3:33 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Follow on information from my latest go round....

loaded the last of the v2 sp 2 items and that went fine. Then I downloaded the entire v3.51 sp as per the website recommendations.

Same problem....

Here's an excerpt from the end of the file named "dd_NET_Framework30_Setup12CD"

The ServiceModelReg tool has completed successfully.
05/04/09 23:05:36 DDSet_Status: Process returned 0
05/04/09 23:05:36 DDSet_CARetVal: 0
MSI (s) (40:60) [23:05:36:328]: Executing op: ActionStart(Name=RegisterFonts,Description=Registe ring fonts,Template=Font: [1])
05/04/09 23:05:36 DDSet_Exit: RunProcess ended
MSI (s) (40:60) [23:05:36:328]: Executing op: ProgressTotal(Total=4,Type=1,ByteEquivalent=180000 0)
MSI (s) (40:60) [23:05:36:328]: Executing op: SetTargetFolder(Folder=C:\WINDOWS\Fonts\)
MSI (s) (40:60) [23:05:36:328]: Executing op: FontRegister(Title=Global Monospace,File=GlobalMonospace.CompositeFont)

This is the normal failure point. I had to execute a system restore to get back to where I was prior to the v3.51 stuff, as usual.

I'm going to post this before I look in the font directory because I imagine as soon as I do the system will hang until I restart and delete Global series of fonts. Again.

Should I just reformat the drive and reinstall?

Left by lfdal54 on May 06, 2009 3:00 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Thanks for this! I just got this error today. I tried using Web Platform Installer- just a simple "error occurred". So I started installing VS.NET 2008 and found the error in a log. You wrote this 2.5 years ago; amazing the error is still there and that the best available documentation is a web blog.
Left by CG on May 26, 2009 10:02 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Hi,
I am trying to install .NET Framework 3.0 on my Windows 2003 Server( with Service pack 1). My Server is already having .NET Framework 1.1 and 2.0, which was installed properly.

While installing .NET Framework 3.0, I am getting error as follows:
[07/08/09,20:11:52] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
"
[07/08/09,20:11:52] WIC Installer: [2] Setup Failed on component WIC Installer
[07/08/09,20:12:15] WapUI: [2] DepCheck indicates WIC Installer is not installed.
[07/08/09,20:12:15] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[07/08/09,20:18:24] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
"
[07/08/09,20:18:24] WIC Installer: [2] Setup Failed on component WIC Installer
[07/08/09,20:18:48] WapUI: [2] DepCheck indicates WIC Installer is not installed.
[07/08/09,20:18:49] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[07/10/09,20:12:14] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
"
[07/10/09,20:12:14] WIC Installer: [2] Setup Failed on component WIC Installer
[07/10/09,20:12:39] WapUI: [2] DepCheck indicates WIC Installer is not installed.
[07/10/09,20:12:39] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[07/10/09,20:43:05] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
"
[07/10/09,20:43:05] WIC Installer: [2] Setup Failed on component WIC Installer
[07/10/09,20:43:30] WapUI: [2] DepCheck indicates WIC Installer is not installed.
[07/10/09,20:43:30] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.

Please email me the solution.

Cheers,
Subodh
Left by Subodh on Jul 10, 2009 10:25 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Bonjour
Je n'arrive pas a instaler net framework 3.0 sur mon PC (Window XP pro 2002 service pack 2)
Il y a déja le 1.1 et le 2.
l'instalation s'interompt voici le journal d'erreur

EventType : clr20r3 P1 : servicemodelreg.exe P2 : 3.0.4506.30
P3 : 4545a225 P4 : mscorlib P5 : 2.0.0.0 P6 : 471ebc5b P7 : 1b08
P8 : 10 P9 : system.security.security

[08/03/09,10:29:11] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
[08/03/09,11:26:37] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
[08/03/09,11:41:17] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
[08/03/09,11:41:34] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
[08/03/09,11:41:34] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[08/03/09,11:45:26] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
[08/03/09,11:45:38] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
[08/03/09,11:45:38] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[08/03/09,12:03:34] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603
[08/03/09,12:03:56] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.
[08/03/09,12:03:56] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.

Quelq'un peut-il m'aidé?

Merci par avance

MANU
Left by MOST on Aug 03, 2009 5:53 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
well.... my first problem is solved but now i cant install the framework 3.5 sp1 =/ Help plz
Left by Andres on Oct 16, 2009 10:05 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
treat the erroe in microsoft.NET Framework
Left by Fatehiya on Oct 27, 2009 12:47 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
this is my error log. pls do help me fix this. :
[10/28/09,22:13:58] VS Scenario: [2] *** Blocking Components exist and must be satisified before continuing to install ***
[10/28/09,22:13:59] VS Scenario: [2] BITS Service
[10/28/09,22:13:59] VS Scenario: [2] *** End of Blocking Component List ***
[10/28/09,22:15:26] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()
[10/29/09,17:59:00] VS Scenario: [2] *** Blocking Components exist and must be satisified before continuing to install ***
[10/29/09,17:59:01] VS Scenario: [2] BITS Service
[10/29/09,17:59:01] VS Scenario: [2] *** End of Blocking Component List ***
[10/29/09,18:02:04] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()
[10/29/09,18:30:47] RGB Rast: [2] Error: Installation failed for component RGB Rast. MSI returned error code 1601
[10/29/09,18:31:00] WapUI: [2] DepCheck indicates RGB Rast is not installed.
[10/29/09,18:31:00] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[10/29/09,18:33:14] RGB Rast: [2] Error: Installation failed for component RGB Rast. MSI returned error code 1601
[10/29/09,18:33:25] WapUI: [2] DepCheck indicates RGB Rast is not installed.
[10/29/09,18:33:25] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[10/29/09,18:51:41] RGB Rast: [2] Error: Installation failed for component RGB Rast. MSI returned error code 1601
[10/29/09,18:51:51] WapUI: [2] DepCheck indicates RGB Rast is not installed.
[10/29/09,18:51:51] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[10/29/09,18:57:17] RGB Rast: [2] Error: Installation failed for component RGB Rast. MSI returned error code 1601
[10/29/09,18:57:27] WapUI: [2] DepCheck indicates RGB Rast is not installed.
[10/29/09,18:57:27] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
[10/29/09,19:09:09] RGB Rast: [2] Error: Installation failed for component RGB Rast. MSI returned error code 1601
[10/29/09,19:09:21] WapUI: [2] DepCheck indicates RGB Rast is not installed.
[10/29/09,19:09:21] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.


anyone who could help will be highly appreciated. thanks. :)
Left by arvin on Oct 29, 2009 6:03 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...

Fixed my issue. ** Removed XP SP3 (If you've installed it) **

Chain of events.

1. New Nvdiva Video card replacing old ATI card. Detected
Video Controler (VGA Compatible), Installed CD; refused due to wininstaller error?

2. Possible conflict with old ATI catalyst software. Removed, Nothing.

3. Ran Driver Sweeper, loading error 0x0000135.

4. Try Updating to NetFrame 3.5 Failed. "Setup did not complete correctly." Try Previous version failed also.

5. Ran .NET Framework cleanup tool (http://astebner.sts.winisp.net/Tools/dotnetfx_cleanup_tool.zip). Didn't fixed the problem.

7. Found this website. Cannot find the "ServiceModel 3.0.0.0" Folder in regedit32. Try to give Adminstration permission to the root folder failed. Try other hints in this thread failed.

6. Removed XP SP3. ;(

Left by BigFire on Dec 24, 2009 11:53 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 says "cannot initialize resources"
Requesting Gravatar...
while installing dotnet 3.0 it says "cannot initialize resources" i already have dotnet 1 install in my computer.
Left by Aslam on Jan 29, 2010 7:25 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
I am a computer idiot!!!!My canon camera software wont install without this microsoft.NET Framework 3.0. I try to install and it keeps saying a problem occured. Not complete????or something like that. I need step by step help. I had it all done before( camera software) but with current fixes on my computer all my info is gone.
Left by jdf on Apr 20, 2010 5:18 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
i had this problem when try installing .NET 3.0

" You must use "Turn windows features on or off" in the control panel to install or configure Microsoft .NET Framework 3.0 x86"

is there anyone know how to fix this?
Left by Fuji on Apr 27, 2010 7:21 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Ok, i keep trying to install ANY of the frameworks and it just gives me and error during the installation. PLEASE HELP.
Left by Nate staats on Jun 01, 2010 12:55 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
works like a charm! :) thanks!
Left by Allanseth on Jul 02, 2010 8:14 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Works like a charm! :) thanks!
Left by Allanseth on Jul 02, 2010 8:15 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Netframework still wont install for me ive gone through the registry stuff and it still wont let me fully install Nero which requires to try installing 3.0 even though i already have it on my system any tips?
Left by Zachary Robare on Aug 22, 2010 8:42 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Hello guys,

Do you encounter errors while deleting files in Windows? I'm here to provide a solution. I've been reading several threads on this topic on different forums where computer users were asking about this popular error "The filename you specified is not valid or too long".

My research helped me to find a tool for you guys.

Its LONG PATH TOOL, a very easy to run but highly powerful software.

Follow the link to read more about this error.

http://www.longpathtool.com
Left by johnylog on Nov 06, 2010 4:24 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
After getting to the Security folder and open it there is no Service Model 3.0.0.0 shown, only an ObjectNames folder which contains no service model file
Left by Louis Llorca on Feb 11, 2011 2:19 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Installer windows server 2003 sur xp professionnel
Left by hakim on Mar 27, 2011 4:39 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
7chi sab3ak fkarak ou ghayssla7 framwork azamal
Left by naama on Apr 05, 2011 1:55 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
7chi sab3ak fkarak ou ghayssla7 framwork azamal fhamte azaab wala la
Left by naama on Apr 05, 2011 1:56 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
turn off your computer

on startup keep pressing f8

select safe mode in the menu that comes up

navigate to C:\program files\reference assemblies\microsoft\framework

delete the folder with the name of the .net version your having trouble with.

if it cannot be deleted

delete the files in the folder

if that doesnt work

make sure your in safe mode

right click the folder and select "properties"

go to "security" tab

make sure your account has "full permissions"

delete the files in the folder.

if that doesnt work

do the things above but this time delete the "microsoft" folder located at C:\program files\reference assemblies.
Left by zeke on Jun 01, 2011 8:23 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
This thread will never end, not as long as there is Microsoft...I set about to install 3.0, because there was this app I wanted to run which required it. Otherwise, I would have quit a looong time ago...I did most of the above, but in particular I removed and reinstalled 1.1 and 2.0. 1.1 and 2.0 appeared in my program lists.

When 3.0 failed, it popped up a message screen ("So, sorry, too bad...") but it also offered an error log. I saved that, wherein it said that I did not have Windows Communication Foundation installed, and therefore, everything following it would not install. I spent fruitless hours looking to download that. Nothing fit. I finally ran a search of my hard drive, and discovered complete folders containing all that already on my computer, contained with 2.0, which was installed. I ran the .exe of the wcf, which failed, then tried to run the 2.0 exe. It only offered to REPAIR the 2.0, so I said, "OK." Ran that, then reinstalled 3.0. It worked! My app works! Now, 3.0 also appears on my program list.

Thank you, everybody. We all have to stick together to win against the machines. That is why I returned here to offer what solution worked for me.
Left by betty on Aug 21, 2011 3:08 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
hi,
i install wn 2003 server and install .net framework 3.5 i got below error

re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.


Please solve this issue and kindly reply
Left by ramajayam r on Dec 22, 2011 12:00 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
hi,

i managed to run this by installing .Net 4.0 first.
Left by bakukang ni hinugasangtubig on Jul 09, 2012 3:13 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
Tnks, are you very helped me!!
Left by sadnasdsadas on Aug 15, 2012 3:40 PM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
I just did an upgrade install from Windows 7 to 8 and one of my games stopped working, complaining about .NET 1.1. I clicked the dialog that popped up for the game and was taken to the Microsoft website where I got .NET 1.1 but when I tried to install it, I got an error:

"to continue with setup it is necessary to reset the windows installer...."

Thanks to this post, I was able to get it to install and now I can play my game! Thanks!!
Left by Nicolai Dutka on Dec 19, 2012 2:18 AM

# re: Error installing .Net 3.0: Microsoft .NET Framework 3.0 has encountered a problem during setup.
Requesting Gravatar...
frnd i am nt finding service model 3.0.0 in my pc and i am using windows service pack 2 ,2002 version, please anybody help me out in installing .netframework 3.0, as i have tried all the above ,yet nt successful
Left by abhay on Mar 09, 2013 1:08 PM

Your comment:
 (will show your gravatar)


Copyright © Tim Huffam | Powered by: GeeksWithBlogs.net