Geeks With Blogs

Tangible Thoughts SharePoint, MOSS? and all the other questions

Something I came across today.

I have a bunch of stsadm backups of WSS sites. Today when I tried to restore one of them after re-installing SharePoint this error screamed at me

“Your backup is from a different version of Windows SharePoint Services and cannot be restored to a server running the current version.”

Guess what – STSADM backups are not version independent. My scenario was a SP1 backup to be restored on a non SP1 box. I do not know if a Pre SP1 backup will restore on a SP1 machine. I haven’t tried it, but I have no reason to doubt whether it would work.

Posted on Thursday, January 13, 2005 10:49 AM SharePoint | Back to top


Comments on this post: STSADM Backup Restore and SP1

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
I have the same problem.
have you the résolution ?

jacques.beyou@cub-brest.fr
Left by Jacques Beyou on Jan 28, 2005 9:50 AM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...

Guys,

I have just experienced the same thing. Has anyone found a way to resolve this?

Thanks
Left by Paco on Jan 28, 2005 11:00 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
Any luck?
Left by Matthew Brewer on Feb 04, 2005 3:46 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
I am currently attempting to restore a SharePoint site using
A) .dat file generated by stsadm
B) a content and config database backup set from sql server 2000

I will let you know how it goes if I dont go **Loco** first...
Left by Parsnips on Feb 09, 2005 7:31 AM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
I had the same problem. I resolve it, by installing the same version of SQL.

Grz P Smolen
Left by smolen45@zonnet.nl on Feb 23, 2005 2:04 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
We has the same problem, and it was the Windows Sharepoint Services version caused it. One server has 6.0.2.6361 and the other is 6.0.2.6411. The later has a Windows Sharepoint Services Patch KB887991 like Sharath pointed out. The patch does not show in "Add and Remove Program". Pretty tricky!
Left by Shuli on Mar 11, 2005 8:11 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
How can i see the versions if it is not listed in the "add and remove programs"? I think i have the same problem. When i try to edit the virtual server, i just get a popop window telling me to upgrade. The version nr on my one portal site is 6.0.2.6361 . I have two webservers that are connected running this site. I think perhaps that one of them have 6.0.2.6361 and the other one 6.0.2.6411. But "add/remove programs" wont tell me anything;)

christian@stolp.no$NOSPAM$
Left by Christian on Apr 06, 2005 12:56 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
Holy Fu***** Christ! I have the same problem as you guys although mine is slightly more worse. We had to reinstall the whole server do to some issues we had. Before we did this we obviously took a backup. We had installed all the updates that was available from winupdate.

And now, that the server is up and running again, I updated the server with all the available updates from winupdate, but when I try to restore I get this error :( is there any way to go around this? Or any solution at all? Now we have no portals what so ever and we go live Septemper 15th!

Please help!
Left by stisve on Sep 09, 2005 10:45 AM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
Just got off the phone with MS. When you do the forceupdate it has to be with the service account used in the application pool in IIS. He fixed a number of problems and straightened out problems I had on my server. BTW...have to do this on the source server then back it up. Can't do this on a target server and try to restore the backup because the source server needs to be fixed first. Nice huh?
Left by Rob on Sep 26, 2005 11:58 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
What if the source server went kaput, and all you have i the backup file?
Totally messed up eh?

I think its always safer to have a smigrate backup as well - heck you dont have security but you still can restore.
Left by Tariq on Sep 27, 2005 4:23 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
Did anyone have issues with forceupdate on source server?
Left by AK on Oct 14, 2005 3:30 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
umm,
'When you do the forceupdate it has to be with the service account used in the application pool in IIS'
What exactly is meant by that?
Left by Chris on Nov 22, 2005 9:53 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
Check the Identity for the application pool that WSS/SPS is running as in IIS.
You will have to use that account to do the force update, I assume
Left by Tariq on Nov 23, 2005 12:31 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
Did anyone fix the problem without having to go back to the source server? I only have the back up files...
Left by Joao Tornovsky on Nov 24, 2005 6:47 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
Here's a tip that helped me immensly:

On my WSS 2.0 server, Control Panel showed me that I had version 6.0.2.6361 ( SP1 Applied), but under site settings on the top level web, it showed 6.0.2.6411, indicating that I had installed the security patch, as well as SP1.

On my server, KB887981 did NOT show up in Add/Remove programs, so I did not think it was installed until I check the version that shows up in the website.

If you are getting the version conflict error when trying to restore, you should probably try a restore 1) with no service pack, then 2)with SP1, then 3) with SP1 plus security update KB887981, then 4) with SP2. Hopefully one of those runs will work for you.
Left by Aaron on Mar 31, 2006 1:42 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
we ended up updating needing to update to 11.0.8000.0.

checked out the properties for stsadm.exe in the back up/ restore file and the ver was 1.8XXXX...we noticed the stsadmn version on the system we were restoring sharepoint to was like 1.5XXXX.

We just copied the stsadmn to the path of the backup to the restore server then found the MS patch for 11.0.8000.0 and tried it out and it worked fine.

We figured out that we were at least ver 6.0.2.6568 so the rest was up hill.
Left by J.B on Jun 12, 2007 8:45 AM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
Hi, have the same problem and got to this article. Hope it helps!

http://msmvps.com/blogs/shane/archive/2007/10/18/please-install-the-sharepoint-updates-on-your-server.aspx
Left by Andres on Dec 06, 2007 5:34 AM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
I can solve it ,
send me an email.
Left by saied on Jul 28, 2010 7:26 PM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
If you have solution, pleasw share it..
Left by caessars on Oct 13, 2010 1:49 AM

# re: STSADM Backup Restore and SP1
Requesting Gravatar...
Even though the WSS admin site reported the same version on both of my servers, it turns out the new one was missing WSS 2.0 SP3. I was able to determine this by comparing versions of 'Microsoft Windows SharePoint Services 2.0' under add/remove programs on both servers.
Left by Bubb Rubb on Jan 20, 2011 11:14 PM

Your comment:
 (will show your gravatar)


Copyright © Tariq | Powered by: GeeksWithBlogs.net