What Was I Thinking?

Follies & Foils of .NET Development
posts - 95 , comments - 352 , trackbacks - 0

Fixing “ResGen.exe" exited with code–1073741701” in Visual Studio 2010

I found this fix online which appears to have resolve this issue, so I wanted to share it here.   I take no credit/responsibility for it, except to say that it has resolved the issue for me.

 

Set the 32-bit flag on resgen.exe

a. Open a Visual Studio command-prompt as an administrator

b. Navigate to the Microsoft SDKs\Windows\v7.0A\bin directory.

c. ***SAVE A COPY*** of your original resgen.exe file.  This is very important if you want to be able to replace our tweak with the original file without having to repair your installation.
copy resgen.exe regen.exe.old

d. Set the 32-bit flag to true using corflags.exe
corflags.exe resgen.exe /32BIT+ /Force

e. Note the warning about strong name issues. On my machine the build now succeeds, without needing to do any additional work due to strong name issues. IF you have problems after trying this method, you can try the following to skip string name verification for that assembly-

f. Register resgen.exe for strong name verification skipping using sn.exe
sn.exe –Vr resgen.exe
WARNING! This is a security risk. You are bypassing strongname verification for this assembly, making it possible for malicious code posing as resgen.exe to execute. To turn verification back on, use sn.exe –Vu resgen.exe

Print | posted on Tuesday, November 23, 2010 11:59 AM | Filed Under [ Visual Studio ]

Feedback

Gravatar

# re: Fixing “ResGen.exe" exited with code–1073741701” in Visual Studio 2010

Worked like a charm. Thanks a lot!
2/1/2011 1:21 AM | Alexey
Gravatar

# re: Fixing “ResGen.exe" exited with code–1073741701” in Visual Studio 2010

Thank you so much for the very helpful workaround.
9/26/2012 6:42 PM | Eric Minbiole
Post A Comment
Title:
Name:
Email:
Comment:
Verification:
 

Powered by: