March 2010 Entries

MOSSLover Lives On…

A while back, maybe 6 months, I got some bad news about 2010. Microsoft was removing Office from the MOSS equivalent of 2010, so basically my alias would be obsolete the second 2010 caught on in the community. I thought about it for some time. I had some discussions with friends in the community. I even noticed that the MOSSMan changed his twitter id. I started my blog around a WSS 3.0 project when I worked for LRS in there St. Louis Office in February/March 2007. So I think it’s fitting to keep ......

Posted On Saturday, March 20, 2010 11:56 PM | Comments (0)

SharePoint Saturday Huntsville in need of Speakers and Sponsors…

So I’ve been to events with Cathy, Lori, and Laura. They are good people. Honestly, the best event I ever attended was SharePoint Saturday Ozarks. I had a crappy week and I got there the actual day of the event. Hanging out with the three of them plus Joy made everything so much better. Then there was devLink and SharePoint Saturday DC and a few other events sprinkled into the mix. I was going to attend Birmingham but the timing was bad and other things occurred. Now I have the opportunity to attend ......

Posted On Wednesday, March 17, 2010 8:50 PM | Comments (0)

Where did my form go in SharePoint 2010!?

So I was working on an intro to development demo for the Central NJ .Net User Group and I found a few kinks. I opened up a form to custom in InfoPath and Quick Published it wouldn’t work. I imed my InfoPath guru friend, Lori Gowin, she said try to run a regular publish. The form was still not showing up in SharePoint. I could open it and it knew my changes, but it would just not render in a browser. So I decided to create a form from scratch without using the button customize form in the list. That ......

Posted On Thursday, March 11, 2010 3:27 PM | Comments (1)

Houston We have a Problem with Silverlight Client OM…

So I was playing around with NavigationNodeCollection, which is basically like SPNavigationNodeCollection just to make sure it worked without a hitch…Here is a little sample snippet of what should work: Unfortunately, you get a nice little javascript error that does not allow you to access the child nodes. I tried a foreach() loop that gets a NavigationNode for each parent then loops through the NavigationNode.Children that did not work either. I threw in two ExecuteQueryAsync statements thinking ......

Posted On Monday, March 8, 2010 5:43 PM | Comments (2)

SPRoleAssignment Crazy Caveats

I’m not sure if this bug exists on any other environment, but here are a few issues I ran into when trying to use SPRoleAssignment and SPGroup: When trying to use Web.Groups[“GroupName”] it basically told me the group did not exist, so I had to change the code to use Web.SiteGroups[“GroupName”]. I could not add the Role Assignment to the Web and run a Web.Update() without adding an additional Web.AllowUnsafeUpdates= true; , however on my virtual machine I could do a Web.Update() without the extra ......

Posted On Friday, March 5, 2010 2:11 PM | Comments (0)

Copyright © MOSSLover

Design by Bartosz Brzezinski

Design by Phil Haack Based On A Design By Bartosz Brzezinski