Geeks With Blogs

News
Jay Kinker
www.mundrisoft.com
www.societyhive.com


Follow me at Twitter My LinkedIn Profile Facebook

Microsoft MVP Logo


Jay Kinker - Entrepreneur, Strategist, Technologist

One of error I received while configuring "Windows SharePoint Services Adapter" for BizTalk Server 2006 is as follows -

Error Msg - "The website selected is not configured with the expected ASP.NET version. The expected version is 2.0, the actual version is 1.1 (CWssadacfg)".

I had both versions (1.1 & 2.0) installed on my box. When I opened IIS Manager to check the version of the selected website - I could not see the ASP.Net tab where you select the default framework version to be used for the website.

My Resolution -

I reinstalled ASP.Net 2.0 with command -
"%SystemRoot%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe" -i

This resolved my problem. However, if this does not work for you then you may try forcefully upgrading SharePoint by -
"%CommonProgramFiles%\Microsoft Shared\web server extensions\60\BIN\STSADM.exe" -o upgrade -url
http://localhost:80 -forceupgrade

More info about STSADM.exe - http://technet2.microsoft.com/Office/en-us/library/188f006d-aa66-4784-a65b-a31822aa13f71033.mspx?mfr=true

Posted on Tuesday, February 20, 2007 4:55 PM Microsoft Technologies | Back to top


Comments on this post: Unexpected ASP.Net version while configuring Windows SharePoint Services Adapter for BTS2006

No comments posted yet.
Your comment:
 (will show your gravatar)


Copyright © Jay Kinker | Powered by: GeeksWithBlogs.net