Geeks With Blogs
CMD Programming with a sawzall MOSS 2007 Microsoft Office SharePoint Server
UpdateProjectWorkspaceAddress fails with WSSWebIsNotProjectWorkspace error
So, I am working on a Proof of Concept that integrates TFS 2008, Project Server 2007 and MOSS. After I create a site based upon a custom site template I then create a project using the PWA web services (UpdateProjectWorkspaceAddr... The project is created but when I try and update the project workspace URL using the wssinterop web service it fails with a WSSWebIsNotProjectWorkspace error. The template has the correct features activated and if I manually (through the PWA Admin UI) set the project ......

Posted On Monday, February 9, 2009 1:08 PM

CQWP, QueryOverride and Columns of type 'User'
I figured I would share an interesting thing I discovered today that appears to be amazingly undocumented. If you use U2U CAML Query Builder to build your CAML queries it creates queries that look like this when querying against columns of type 'User': <property name="QueryOverride" type="string"> <![CDATA[<Where>&l... Name='Author' /><Value Type='User'>[Me]</Val... </property> And that query will not work. It will ......

Posted On Monday, December 15, 2008 11:46 AM

WSS vs Portal Server Service Pack mismatch
Ok. I have dealt with mismatched version numbers between servers countless times in both SharePoint 2003 and 2007 when transferring data between two environments. What I had not run into (until today) was the fact that WSS 2.0 can be updated (SP3) while Sharepoint Portal Services was bone-stock-out-of-the-box. It took me a bit to figure out what was going on. I was attempting to restore a 2003 site into a test environment but was getting the dreaded "Your backup is from a different version of Windows ......

Posted On Thursday, November 20, 2008 12:34 PM

List Does Not Exist
In working through an issue with workflow I stumbled across an interesting 'feature' of workflow and MOSS. Essentially I have a "Project Sites" root web where I am creating child sites via a workflow: Project Sites Child Site 1 List 1 List 2 In these child sites I am creating some lists and setting alerts on them based upon things that happen in the workflow. In attempting to create an alert on a list, I received a "List does not exist" error. In stepping through the code and inspecting all the objects ......

Posted On Tuesday, November 18, 2008 10:34 AM

Copyright © CMD | Powered by: GeeksWithBlogs.net