Geeks With Blogs

Blue Probe It’s the parting gift when you host an alien abduction

I kept failing installing the JBOSS tools into Eclipse. I even tried downloading the archive to install from https://www.jboss.org/tools/download/stable/3_2_GA. The problem was Java 1.7. Even with my classpath and JAVA_HOME set to point to Java 1.6, there was still something out of whack (java –version would show 1.7). Stopping Eclipse, and uninstalling Java 1.7, proved to be the solution. Here is the error:

An error occurred while collecting items to be installed

session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

Comparison method violates its general contract!

Posted on Monday, November 7, 2011 10:08 PM | Back to top


Comments on this post: Eclipse Helios- Error installing JBOSS tools

No comments posted yet.
Your comment:
 (will show your gravatar)


Copyright © Ken Hortsch | Powered by: GeeksWithBlogs.net