Geeks With Blogs
Hornet's Nest A few of Mike Hoerner's Favorite Topics


When we started our Exchange 2010 deployment, we ran into an issue with not being able to modify distribution lists.  I documented how to fix this issue in a previous post.

Not too long ago, we started getting a few reports from users with Exchange 2010 mailboxes that they could not modify their distribution lists and the error message they were getting was the same error message we saw when we started deploying Exchange 2010.  When an user attempted to modify a distribution list they owned, they would get a “Changes to the distribution list membership cannot be saved.  You do not have sufficient permission to perform this operation on this object.” error message.

E2K10-5 

After we confirmed that no one made any changes to the RBAC role outlined in Matt Byrd’s article, we started troubleshooting the problem.  Shortly thereafter, we noticed that when we tried to view the properties of the distribution lists users were having trouble modifying using the Exchange Management Console, we would get a properties on this object have invalid data error message.

E2K10-6

After acknowledging the error message above, we would get a some controls are not valid error message.  It would state either the property value is invalid or the property expression isn’t valid.

E2K10-8

E2K10-10 

After we removed a trailing space from a DL Display name, removed two brackets () from a DL Alias name, and removed one or more spaces from a DL Alias name and waited for Active Directory replication to complete, users were able to modify their distribution lists successfully.

So, if you have users with problems modifying their distribution lists in your environment, review their distribution lists, especially the Display name and/or Alias name, and make sure their distribution lists are not using unsupported characters.

Posted on Tuesday, May 10, 2011 1:29 PM | Back to top


Comments on this post: Exchange 2010 Troubleshooting – Another Distribution List Issue

# re: Exchange 2010 Troubleshooting – Another Distribution List Issue
Requesting Gravatar...
I had this issue with some user accounts. To fix this, I had to set the domain next to the user logon name in Active Directory. The accounts had been added via script and the domain had not been set automatically.
Left by Rob on Sep 08, 2011 7:13 PM

Your comment:
 (will show your gravatar)


Copyright © BWCA | Powered by: GeeksWithBlogs.net | Join free