Geeks With Blogs

News Copyright © 2008-2013 Paula DiTallo
Ask Paula! ...bringing you notes from the field...

Perhaps you've experienced the scenario where you hit the F5 key on the Group Overview in the BizTalk Admin console and instead of seeing your message queues, you see instead the very ugly () message: 

Failed to create a CLSID_BizTalkPropertyBagFactory COM component installed
with a BizTalk server. A dynamic link library (DLL) initialization routine
failed. (WinMgmt)

Go to the event viewer and look for any COM/COM+ errors under applications. Chances are you will see a conflict with WMI services--perhaps a threading error. Since the SSO, BizTalk Admin Console, SCOM...(even event viewer) use WMI for the MMC console, one of the DLLs for WMI may have become unavailable. If WMI is not available, or the WMI service has crashed,  the console for the BizTalk Admin  can fail with this error message as its swan song ().

Aaron Tiensivu's blog offers a way to isolate WMI issues on svchost:

http://blog.tiensivu.com/aaron/archives/294-Suspect-that-WMI-is-crashing-your-SVCHOST-Run-it-standalone..html

There are 2 solutions that I know of, 1 radical and 1 less so...

  1. restart the server [waaay radical, but effective]
  2. restart the WMI windows service

 

 

 

 

Posted on Tuesday, January 20, 2009 10:16 AM Practical Answers , BizTalk | Back to top


Comments on this post: Why am I getting the error: CLSID_BizTalkPropertyBagFactory error in the BTS Admin console

No comments posted yet.
Your comment:
 (will show your gravatar)
 


Copyright © Paula DiTallo | Powered by: GeeksWithBlogs.net | Join free